viernes, 19 de junio de 2009

Instalar facilmente archivos .tar.bz2 y .tar.gz

Bueno aqui es donde caemos generalmete los nuevos usuarios de linux, cuando nos descargamos algun programita para probar, drivers o un jueguito por ai, casi todos en cualquier distribucion de linux llega de primera mano en estos tipos de archivos.

Los archivos .tar vienen de ser usados en UNIX para almacenar archivos y otros directorios.
http://es.wikipedia.org/wiki/Tar

Los archivos .bz2 (BSD Zip 2) y .gz (GNU Zip) en realidad simplemente son el formato de compresion.
http://es.wikipedia.org/wiki/BZ2
http://es.wikipedia.org/wiki/Gzip

Ok ahora manos a la obra:

Una ves descargado el archivo .tar.bz2 o tar.gz sencillamente le damos el famoso click derecho y seleccionamos "Extraer aqui" o podemos hacer esto abriendo un terminal y posicionandonos en el directorio donde esta nuestro archivo de esta manera

*Consejo: facilmente puedes con click derecho elegir copiar al directorio y en el terminal seleccionar "Editar" -> "Pegar" y te pega la dirección del directorio

$cd "Direccion"
Por ejemplo:
$cd /home/jr/descargas

y para finalmente descomprimir el archivo tecleamos

$tar -zxvf "nombreprograma".tar.gz
$tar -jxvf "nombreprograma".tar.bz2

Una ves hecho esto nos posicionamos en el directorio recién creado

$cd "nombreprograma"

Después digitamos

$./configure

Debemos ver si el configure no lanza algún error, generalmete lo hace porque nos falta algún paquete en especial que requiere el programa para funcionar o el que tienes instalado es muy antiguo u obsoleto. Caso encuentra algún error este saldrá entre las ultimas 15 lineas, para solucionar esto puedes instalar el paquete que se requiera desde el Synaptic, buscando por su nombre que indico el configure. Una ves instalado el paquete que faltaba nos volvemos a la terminal y digitamos

$./configure

Verificamos que no salgan mas errores o sino seguimos instalando los paquetes que falten hasta que no aparescan mas.
Una ves terminado esto podemos seguir la instalación tecleando en el terminal

$make

Y para terminar

$make install

Eso es todo para poder instalar un archivo de tipo .tar.bz2 o tar.gz , no deberíamos tener mas problemas para realizar esta tarea que después de algún tiempo usando Linux es rutinaria.
Para ejecutar el programa recién instalado buscamos su lanzador en el menú de aplicaciones, si por algún motivo no se creara, puedes digitar en el terminal el nombre del programa instalado.

*Consejo1: si digitas el comienzo de algún comando o programa en el terminal y apretas "TAB", el mismo terminal completa la palabra.

*Consejo 2: no es mala idea probar agregar la palabra sudo antes de cada comando, generalmente si es necesario el sudo (ejecutar como superusurio) te lo dira en la consola que no tienes los permisos suficientes.

Bueno espero que le pueda ser de utilidad esta pequeña guia, cualquier consulta haganlas en los comentarios.

83 comentarios:

  1. Muy bueno sencillo practico.
    Tefelicito por tu blog.

    ResponderEliminar
    Respuestas
    1. Es más sencillo instalar cualquier cosa en windows (.exe) ;)

      Eliminar
    2. Si, incluyendo los virus

      Eliminar
    3. E igual de sencillo es difundir un virus en windows xD

      Eliminar
    4. Ya estamos en pleno 2013 y hasta el dia de hoy se mantiene un metodo de instalacion que a comparacion de la facilidad que te brindan los exe, parce de la edad de piedra.

      Eliminar
    5. cuando se te infecte la computadora con miles de virus, vas a desear haber instalado todo de la forma dificíl xD

      Eliminar
  2. esta bien y si esta util :) gracias por la informacion bro.

    ResponderEliminar
  3. Excelente bun post en tu blog, me fue muy util

    ResponderEliminar
  4. Hola:
    estoy intentando instalar el Songbird. Lo he descargado varias veces; lo tengo como una carpeta normal y como tar.gz en /home/a.../descargas. Bien, pues cuando voy al terminal y tecleo cd /home/a.../descargas me devuelve el mensaje de que no existe el directorio. Soy nueva en linux y no entiendo que puedo estar haciendo mal. Por cierto, tengo el ubuntu karmic, por si sirve de algo..
    Gracias y saludos.

    ResponderEliminar
    Respuestas
    1. la palabra descarga va con D mayuscula ejemplo
      cd home/usuario/Descarga

      Eliminar
    2. Descargas (con ese al final) jeje :)

      Eliminar
  5. hola

    me sale un error ... dbus ... no
    configure error: D-Bus library is required

    a que se debe ??

    Gracias de antemano...

    ResponderEliminar
  6. Hola Soy nuevo en ubuntu, ya pude instalar facilmente del manager algunas aplicaciones, tambien las de formato .dat pero quiero instalar un simple tema para mi sistema y me descargan formatos tar.gz , le he dado con muchisimos tutoriales que encuentro en la red y ninguno me ha dado resultado, esto de usar esta terminal basura ya me tiene enojado y estoy por dejar este sistema operativo, no he instalado ningun miserable programa con esta vendita terminal, aver si alguien se le ocurre hacer algo con el manager para que instale estos archivos, en verdad me tiene...esta...

    ResponderEliminar
    Respuestas
    1. hola yo tengo ubuntu en una maquina virtual no he probado a instalar un tema pero vi que en fedora se arrastra el tema al gestor de temas de escritorio o algo asi

      Eliminar
  7. Muy bueno tu aporte pero me limo la cabeza.... un abrazoo

    ResponderEliminar
  8. voy a probar, espero lograrlo, se ke despues de un tiempo y de cometer algun ke otro error, se logra, asi es linux...

    ResponderEliminar
  9. quiero instalar el quicktime para poder ver videos 3gp porque con otro reproductor no he podido y hay una distribucion ahora para linux, pero viene en .tar

    ResponderEliminar
  10. El problema es que cuando le doy "./configure" me sale:

    bash: ./configure: No existe el fichero ó directorio

    No me sale nada luego, no puedo ver si me falta algo del synaptic o donde porque no me abre el configure. Demasiado quiero probar el beta de firefox 4 ¡ayudame por fa! xD

    ResponderEliminar
  11. Hola anonimo del primer comentario con problema, jejeje, te aconsejo que lo copies en otro lugar, talves es algun error con la direccion digitada, suele pasar.

    Al siguiente anonimo que tiene problema, lo que pasa es que claramente te indica que te falta la libreria D-Bus, buscala e instalala, eso deberia solucionar tu problema.

    Hola tercer anonimo, (much@s anonimos...) no te desanimes, es solo tener un poco de perseverancia y buscar en google, de todas maneras aqui te ofresco mi ayuda, todo sea por el software libre.

    Muy bien dicho German Borges , te felicito, y ante cualquier problema consultas aqui. Para ver .3gp hay otras opciones que el Quicktime porque no pruebas esas, te lo aconsejo. Saludos

    GuilleMurto: recuerdo algo parecido me paso a mi, si no me equivoco era porque un archivo estaba dentro de una carpeta y no en la carpeta principal donde se compila, trata de revisar eso, de todas maneras tambien planeo instalarme el Firefox 4 beta en mi ubuntu asi que te comento como me fue mas adelante. Saludos

    A todos los demas gracias por los comentarios y sigan visitando el blog.

    ResponderEliminar
  12. gracias.... excelente para los novatos que apenas nos iniciamos...

    ResponderEliminar
  13. de nada, mas bien gracias a ti por la visita XD

    ResponderEliminar
  14. debes explicar de mejor manera la instalacion en la primera parte...

    ResponderEliminar
    Respuestas
    1. hola esta explicado bien ....

      Eliminar
  15. podrias ser mas especifico de que parte?

    ResponderEliminar
  16. hola
    pues me parecio algo interesante su informacion, pero creo que pudieron ponerle mas creatividad, de todos modos buena informacion.

    ResponderEliminar
  17. el directorio home/..../descargas va con mayuscula en Descargas por eso les dice que no existe el directorio. Lo correcto es
    home/...../Descargas/nombredelarchivo

    ResponderEliminar
  18. home/Hugo/Descargas es lo correcto

    ResponderEliminar
  19. yo no pude hacer ni madres

    ResponderEliminar
  20. despues de extraer archivos y pegar en terminal
    esto es lo que me aparece
    eragon33bacili@ubuntu:~/Descargas/win2k_xp1418$
    son los drivers de aceleracion de video
    pero ya despues los otros comandos
    no funcionan ni ./configure
    ni make install
    y no me manda ningun error
    como dato complementaro el cursor se queda al final del comando despues de 418$

    ResponderEliminar
  21. etham mejor si pegas todo el proceso que has hecho en la terminal aqui, aveces no es necesario hacer el .\configure, simplemente el make, pero tienes que estar en la carpeta correcta, tambien serviria saber que tarjeta de video tratas de instalar para que te ayude, saludos.

    ResponderEliminar
  22. otra cosita mas, no publique tu primer comentario pq mostraba tu correo electronico, segun las condiciones y normas del blog no publicamos direcciones de correo electronicos para asi facilitar la comunicacion con nuestros lectores

    ResponderEliminar
  23. Makefile:17: *** falta un separador. Alto

    ResponderEliminar
  24. manuel@UnPc:~$ cd /home/manuel/Descargas
    manuel@UnPc:~/Descargas$ tar -zxvf NVIDIA-FreeBSD-x86-71.86.14.tar.gz
    NVIDIA-FreeBSD-x86-71.86.14/
    NVIDIA-FreeBSD-x86-71.86.14/x11/
    NVIDIA-FreeBSD-x86-71.86.14/x11/driver/
    NVIDIA-FreeBSD-x86-71.86.14/x11/driver/Makefile
    NVIDIA-FreeBSD-x86-71.86.14/x11/extension/
    NVIDIA-FreeBSD-x86-71.86.14/x11/extension/Makefile
    NVIDIA-FreeBSD-x86-71.86.14/x11/bin/
    NVIDIA-FreeBSD-x86-71.86.14/x11/bin/Makefile
    NVIDIA-FreeBSD-x86-71.86.14/x11/Makefile
    NVIDIA-FreeBSD-x86-71.86.14/lib/
    NVIDIA-FreeBSD-x86-71.86.14/lib/compat/
    NVIDIA-FreeBSD-x86-71.86.14/lib/compat/libGL/
    NVIDIA-FreeBSD-x86-71.86.14/lib/compat/libGL/Makefile
    NVIDIA-FreeBSD-x86-71.86.14/lib/compat/libnvidia-tls/
    NVIDIA-FreeBSD-x86-71.86.14/lib/compat/libnvidia-tls/Makefile
    NVIDIA-FreeBSD-x86-71.86.14/lib/compat/libGLcore/
    NVIDIA-FreeBSD-x86-71.86.14/lib/compat/libGLcore/Makefile
    NVIDIA-FreeBSD-x86-71.86.14/lib/compat/Makefile
    NVIDIA-FreeBSD-x86-71.86.14/lib/libGL/
    NVIDIA-FreeBSD-x86-71.86.14/lib/libGL/Makefile
    NVIDIA-FreeBSD-x86-71.86.14/lib/libnvidia-tls/
    NVIDIA-FreeBSD-x86-71.86.14/lib/libnvidia-tls/Makefile
    NVIDIA-FreeBSD-x86-71.86.14/lib/libGLcore/

    ResponderEliminar
  25. no puedo ayudarte si no copias absolutamente todo lo q digitaste en la terminal y todo lo que esta mostro, generalmente si te fijas mas arriba del error encontras una linea que dice, falta tal cosa o no se pudo hacer tal cosa.

    ResponderEliminar
  26. No puedo instalar thunderbird-3.1.9.tar.bz2 en Ubuntu 10.10
    Gracias por la ayuda.

    ResponderEliminar
  27. Pq no puedes instalar? cual es el problema?

    ResponderEliminar
  28. En serio que no entiendo, no sé si soy muy ignorante, pero he visto ya como 7 tutoriales y no entiendo que es lo que hay que hacer, porqué carajos no es como un simplea archivo .exe de windows?

    ResponderEliminar
  29. tranquilo hombre que nada es imposible, para empezar donde es que te pierdes?
    Ahora yo te pregunto porque quieres que sea como un simple exe y estas en linux?, para eso ve y usa windows así te ahorras el lió, porque en un instalador común de windows no tienes las posibilidades de mejorar las librerías o peor aun ni sabes que librerías, dll, datos en el registro se hacen, en cambio en linux tienes muchas posibilidades de personalizar tu instalación, saber que es lo que usa y que no y muchas otras ventajas que me quedan cortos los comentarios.
    Saludos

    ResponderEliminar
  30. perdi mas de 30 minutos intentando instalar exaile-0.3.2.tar.gz hasta que di con otro tutorial que menciona entrar sudo antes de cada comando.
    por favor dar las indicaciones completas.

    ResponderEliminar
  31. mira si quieres un consejo, trata primero de instalar lo que tu quieras por medio de los gestores de software que ya tienen la mayoria de las distribuciones de linux, si no lo encuentras alli puedes buscar en el synaptic, caso tampoco este te recopiendo buscar los archivos de instalacion que tiene linux, dependiendo de tu distribucion, si esta basada en debian busca archivos .deb , si esta basada en red hot o fedora busca archivos .rpm y por ultimo trata de instalar los archivos .tar .
    Esto te lo aconsejo si estas iniciando o no tienes muchos conocimiento pero con el tiempo y practiva veras que las cosas se facilitan mucho.
    Ya agrege como consejo 2 en la entrada tu sugerencia, muchas gracias por la misma y por visitar el blog, saludos.

    ResponderEliminar
  32. Hola, en primer lugar, muchas gracias por tu esfuerzo! tengo un serio problema después de la descompresión, tras entrar en la carpeta pertinente, pero cuando uso el comando ./configure me da este resultado:
    laptop@laptop-laptop:~/Downloads/thunderbird$ ./configure
    bash: ./configure: No such file or directory

    Intento directamente usar el make install pero me lleva a este mensaje:
    laptop@laptop-laptop:~/Downloads/thunderbird$ make install
    make: *** No rule to make target `install'. Stop.


    Muchas gracias de antemano ;)

    ResponderEliminar
  33. En ves de ./configure Prueba lo sgte:

    # perl Makefile.PL
    # make
    # make install

    Eso aparece en el README de ora2pg

    Espero sirva a los futuros lectores !

    Saludos, Silvana :)

    ResponderEliminar
  34. excelente aporte... justo lo que estaba buscando... GRACIAS....

    ResponderEliminar
  35. hola soy nuevo en ubuntu y cuando ejecuto el make me aparece lo siguiente

    make: *** No se especificó ningún objetivo y no se encontró ningún makefile. Alto.

    ResponderEliminar
  36. en todos los blogs que entro para realizar consultas me encuentro con lo mismo.comandos que en teoria me van a salvar la vida y JAMAS es asi.aunque se hable del mismo ubuntu que utilizo.llevo un tiempo con ubuntu y todo son problemas a la hora de hacer casi cualquier cosa.al final he optado por instalar desde centro de software o synaptic pero me gustaria poder instalar aplicaciones de otros sitios tambien confiables y siempre es lo mismo.en teoria esto es tan simple como extraer un zip o un rar y nada mas lejos de la realidad.gracias de todos modos.

    ResponderEliminar
  37. nada me sirve mismo error quiero instlar samba 3.5.11 ya que no puedocomprtit archivoscon mi hermanoelusa windows 7, ypor masque leo nadie dauan respuesta concreta ami elerror que sale es:
    bash: ./configure: No such file or directory
    y de ahi no pasa, yo tengo como 1 año 8mees usando ubuntu, el problema deusar ubuntu y porlo cual mucha gente se desanima es ppor los problemas de instalcion de este tipo de archivos CITO a Jr "recuerdo algo parecido me paso a mi, si no me equivoco era porque un archivo estaba dentro de una carpeta y no en la carpeta principal donde se compila, trata de revisar eso" y que reviso o que carpeta o que hago, se agradeceria su amable ayuda

    ResponderEliminar
  38. gracias pero no funciona. llevo tres meses con el ubuntu, en cada sitio que busco dan unos comandos distintos y metodos distintos para hacer estas cosas y no funcionan casi nunca. es un sistema operativo que te complica en vez de facilitar, estoy por cambiar otra vez a la ruina de windows.
    gracias de todas formas

    ResponderEliminar
  39. HOla amigo gracias por el esfuerzo. TE agradesco la ayuda y es uno de los tutoriales que mas aprendi.

    Pero tengo un problema.
    Uso ubuntu 1.10 y quiero instalar firefox 8 y me quedo en la parte de ./configure me sale

    bash: ./configure: No existe el archivo o directorio

    Hay varios con este problema he intente con el ultimo comentario y tampoco. TE lo agradeceria de antemano ya tengo dos dias buscando guias y nada. gracias

    ResponderEliminar
  40. Es una mierda todo esos problemas que te da linux para instalar un programa, ¿ porque no es como windows que haces doble click en el instalador y ya esta ? ... para que mierda quiero estar aprendiendo todos esos comandos si lo que quiero es solo ejecutar un programa , si hubiese querido aprender esos codigos hubiese ido a estudiar programacion , gracias por la explicacion ...

    ResponderEliminar
  41. para los que qieran instalar firefox en su ultima version, y thunderbird en su ultima version, descarguen el archivo .tar.bz2 ejemplo: firefox.tar.bz2, basta con descomprimirlo, ingresamos a la carpeta no necesariamente por terminal, ubicamos el archivo que tiene el nombre firefox,solo ese no tiene ni un punto ni nada solo firefox, le damos doble click y tendremos nuestro programa ejecutandose, y ahora solo debemos crear un lanzador para este firefox, podemos usar el quee esta en el panel, le hacemos click con el boton derecho sobre el icono de firefox luego damos click en propiedades, no mostrara una ventana donde sale el logo de firefox donde dice Navegador web y laruta del ejecutable de la version antigua, pues bien esa ruta debemos cambiarla por la ruta de la nueva version damos click en examinar en la ventana que se habre ubicamos la carpeta de firefox de la ultima verion que ya se encuenta descomprimida y elegimos el archivo firefox(que no tiene ningun, punto algo) le dramos en abrir no reemviara a la ventana donde se encontra puesta la nueva ruta, damos click en cerrar y listo.

    ResponderEliminar
  42. Hola, me manejo con una versión de ubuntu 10.04., con una versión de Thunderbird vieja, actualizada hasta la 3.0. Necesito migrar todo los correos y direcciones a una nueva instalación y ahí la versiones de tuhunderbird que vienen con un nuevo paquete instalación de ubuntu 10.04. o posterior, tienen una estructura de archivos distinta y lo que hacía antes, ahora no funciona.

    ¿Alguien puede ayudarme sobre cómo hacer para resolver mi problema?

    ¡Muchas Gracias!

    ResponderEliminar
  43. bueno señor mubhas gracias por ayudar a los iniciados en este mundo de unix soy novato y se prende mucho de las sugerencas errores y patalequeos que se tienen con este sistema soy wiljsal venezuela

    ResponderEliminar
  44. gracias por ayudar al os iniciados en este nuevo mundo sistematico sus consejos me han servido de mucho al ver las sugerencias que le dan alos novatos mil gracias

    ResponderEliminar
  45. He pasado por aqui, algo he aprendido, porque quiero empezar con Linuz de forma seria y no veo por delante mas que una montana(perdona la ortografia deficiente,tengo teclado ingles y me cuesta adaptarme, ademas no domino todavia el espanol).
    Se agradece tu forma mui comprensible de explicar. Volvere...!!!Photonel67

    ResponderEliminar
  46. lo siento NO te entendi NADA :/

    ResponderEliminar
  47. Esto no es nada facil jejejej
    Yo desintalare esta mierda y me quedo con windows y el espacio que me ocupa esta basura de OS. jajaja

    ResponderEliminar
  48. yo me quedo con windows y con el espacion que me ocupa esta basura de OS ya que lo decintalare.

    Unos dicen que se instala de una forma y otros de otra.
    Como windows nunguno jamas. nosotros buscamos mas rapides no lentitud en las instalaciones.

    ResponderEliminar
  49. Excelente, llevo años en Linux me pierdo cuando dejo de practicar, están fácil si uno aprende solo falta paciencia. GRACIAS

    ResponderEliminar
  50. Verificamos que no salgan mas errores o sino seguimos instalando los paquetes que falten hasta que no aparezcan mas.
    Una ves terminado esto podemos seguir la instalación tecleando en el terminal

    Esta es la parte que le falta informar a los demás bloca de Linux, no sabia que hacer cuando seguían saliendo "error" y desistía de la instalación. Muy bien explicado felicitaciones

    ResponderEliminar
  51. kichanmaster@ubuntu:~$ $cd/home/kichanmaster/Descargas
    bash: /home/kichanmaster/Descargas: Es un directorio
    kichanmaster@ubuntu:~$ $tar -jxvf FoxitReader-1.1.0.tar.bz2
    -jxvf: no se encontró la orden

    Men mira lo que me sale, ayuda!
    MUY BUEN BLOG!!!
    GRACIAS

    ResponderEliminar
  52. no entiendo esa parte que dices "nos posicionamos en el directorio"
    Por favor Podrías ser más gráfico? podrías poner ejemplos

    ResponderEliminar
  53. no entendi nada, explicalo con mas detalle soy nuevo en ubuntu

    ResponderEliminar
  54. NO FUNCIONA NADA Maldito sistema libre... Prefiero Windows.

    ResponderEliminar
  55. `w3af tar -xvf nombre_del_archivo.tar.bz2`

    esto es la manera en que he escrito el susodicho ...primero el programa, w3af,

    luego lo que sigue, tal y como esta!!! ;)

    ResponderEliminar
    Respuestas
    1. es una lata que no se pueda instalar un misero programa sin tener que leer largos tutoriales que ni escriben bien y en los cuales no ponen todos los comandos, es tan simple señores, porque no crean instaladores con 2 opciones elegibles, una simple para novatos y una avanzada para los que tienen tiempo para perderlo en un software libre pero bobo como el pingüino porque lo cambian a cada rato y por eso a cada rato hay que estar solucionando errores de los betas tras betas que hacen de ubuntu y otros

      Eliminar
  56. una cuantas imagenes no estarian mal...........

    ResponderEliminar
  57. Gracias, es la primera palabra que deseo pronunciar, copie tu tutorial y lo pegue en el escritorio, lo repetí varias veces hasta que le encontré la *mano*.
    Quería aprender otra forma de instalar que no fuera con *alien* y con tu tutorial me siento Carlitos Gardel. Gracias, nuevamente y saludos desde Córdoba, Argentina.

    Jorge

    ResponderEliminar
  58. Gracias, es la primera palabra que deseo pronunciar, copie tu tutorial y lo pegue en el escritorio, lo repetí varias veces hasta que le encontré la *mano*.
    Quería aprender otra forma de instalar que no fuera con *alien* y con tu tutorial me siento Carlitos Gardel. Gracias, nuevamente y saludos desde Córdoba, Argentina.

    Jorge

    ResponderEliminar
  59. Me alegro mucho de leer tu comentario tim, que bueno que este blog sea util, y espero lo siga siendo por mucho tiempo.
    Saludos y suerte con linux!

    ResponderEliminar
  60. Hola Jr.
    Un gusto encontrar este tipo de blogs.
    Yo intento hacer andar samba en una maquina con ubuntu 10.10 para migrar cientos de Gb a otra con ubuntu 12 y no puedo instalarlo en la primera.
    Me dice "arregle los paquetes rotos primero"
    Pero ni idea como hacer eso.
    después intente buscar Samba en Synaptic y me dice que hay dependencias irresolubles como esta:
    " Depende: samba-common (=2:3.5.4~dfsg-1ubuntu8) pero se va a instalar 2:3.5.4~dfsg-1ubuntu8.4
    Depende: libwbclient0 (=2:3.5.4~dfsg-1ubuntu8) pero se va a instalar 2:3.5.4~dfsg-1ubuntu8.4"
    Como otras veces logre compilar programas bajados con el método que bien indicar en el post lo intente, bajándome Samba-4.0.3 que es la última, pero al configurar me salen muchísimos errores.
    Llevo mas de 15 años usando linux y muy pocas veces tuve problemas, pero esta vez no logro sortearlo.
    Si pudieras orientarme me vendría muy bien.
    Muchas gracias

    ResponderEliminar
  61. Saludos Gamar,
    De primera mano te recomendaria actualizar tu ubuntu 10, osea los repositorios y todo el sistema, no me refiero a la version, una ves hecho esto trata de instalar samba desde los repositorios, es mas sencillo asi ya que las versiones mas nuevas generalmente tienen dependencias mas nuevas, si esto no diera resultado igual podrias tratar de hacer una red local pero no usando samba, que el modo de conexion que usa MS Win, como en tu caso son ambos linux me parece que no tendras problemas, en ultima instancia si esto no resultase yo usaria alguna distribucion linux con live cd que incluyera samba pre instalado, o alguna que no sea muy complicada de manejar, como Slitaz que puedes usarla en un usb y instalar facilmente samba como en este post que tengo aqui en el blog. Espero haberte ayudado y cualquier otra duda puedes dejarla en un comentario.

    ResponderEliminar
  62. http://goorge.blogspot.com/2012/05/instalando-y-configurando-samba-en.html

    ResponderEliminar
  63. Lo de paquetes .tar.gz si que es problema, por mas que se lea README al menos en FEDORA, creo no estoy seguro al 100 % pero ese tipo de paquetes son tan antiguos por ser UNIX; tendras algun tuto sobre un programa instalado en FEDORA extension .tar.gz pero que si haya corrido. Muy bueno tu blog. Felicidades.

    ResponderEliminar
  64. Gracias por el aporte! Está bueno, es simple y me fue muy útil.

    ResponderEliminar
  65. Gracias me ha ayudado de mucho por fin puede instalar "Vuze" para bajar musica te agradezco enorme sencillo y practico.

    Saludos desde Monterrey, Mexico

    ResponderEliminar
  66. Gracias muy útil realmente

    ResponderEliminar
  67. un favor si puede indicarme cual es el comando para añadir al ./configure --prefix
    para que encuentre un archivo ya instalado. el error que muestra es:
    checking for pygtk 2.24 installed... not found
    configure: error: required pygtk version not found.
    pero el pyqtk 2.24 lo tengo instalado en: /usr/lib/pygtk /usr/local/lib/pygtk /usr/share/pygtk.
    estoy tratando de actualizar soundconverter a la version soundconverter-2.0.4 en ubuntu 10.10 mi computador es bastante antiguo para actualizar ubuntu a una version mas moderna.
    ya en una ocacion habia encontrado como hacerlo pero no recuerdo donde.
    gracias por la ayuda que pueda brindar
    miguel


    ResponderEliminar
  68. Hola, realice todos lo pasos y al teclear ./configure me manda esto:

    [jose@jose Descargas]$ cd "aSensors"
    [jose@jose aSensors]$ ./configure
    bash: ./configure: No existe el fichero o el directorio

    ResponderEliminar
  69. Muy util. Haz sido un salvavidas, pues ni me acordaba cómo descomprimir archivos.
    Muchas gracias por la info.

    ResponderEliminar
  70. hola amigo me ha sido de utilidad porque avia una actualización de firefox 26 y estaba jugando en habbo por unos minutos después vi que avía que actualizar el flash y no podía seguir jugando así que busque frustrado pero por fin vi este tuto. una pregunta cada ves que instalo algo me da cosa dejar ese poco de carpetas, archivos y cosas en otras carpetas ¿puedo eliminar la carpeta que extrage? y si la dejo es normal tenerla por ejemplo en mi carpeta de descargas(donde tengo muchos programas también instalados XD)? me gustaria que me dijeras si todos los programas se pueden pasar a la raiz osea mas "ordenado".

    ResponderEliminar
  71. Saludos Horangel
    Me parece que no deberia haber ningun problema al eliminar la carpeta, aunque existe la posibilidad de una instalacion que solo vincule un ejecutable a esa carpeta, la mejor forma es probando en cortarla a otra direccion y si el programa en si se ejecuta no habria problema en eliminarla. Tambien puedes copiar las cosas a la raiz, siempre y cuando no se sobrescriba nada pero me parece que no seria recomendable, mejor te aconsejaria crear una carpeta dentro de tu directorio de usuario o de la carpeta descargas, algo como "software instalado" y alli colocar todo, por si en algun momento deseas reinstalar o compartirlo, espero haberte ayudado.
    Suerte!

    ResponderEliminar